목록전체 글 (245)
일상 코딩
https://www.acmicpc.net/problem/2110 2110번: 공유기 설치 첫째 줄에 집의 개수 N (2 ≤ N ≤ 200,000)과 공유기의 개수 C (2 ≤ C ≤ N)이 하나 이상의 빈 칸을 사이에 두고 주어진다. 둘째 줄부터 N개의 줄에는 집의 좌표를 나타내는 xi (0 ≤ xi ≤ 1,000,000,000)가 www.acmicpc.net N, C = map(int, input().split()) X = sorted([int(input()) for _ in range(N)]) sta = X[1] - X[0] end = X[-1] - X[0] result = 0 while sta = val + mid: val = X[i] cnt += 1 if cnt >= C: sta = mid + ..
https://www.acmicpc.net/problem/1236 1236번: 성 지키기 첫째 줄에 성의 세로 크기 N과 가로 크기 M이 주어진다. N과 M은 50보다 작거나 같은 자연수이다. 둘째 줄부터 N개의 줄에는 성의 상태가 주어진다. 성의 상태는 .은 빈칸, X는 경비원이 있는 칸이다 www.acmicpc.net N, M = map(int, input().split()) B = [list(input()) for _ in range(N)] cnt = 0 def X_check(arr): ret = 0 for i in arr: if 'X' in i: continue else: ret += 1 return ret def rotated(array_2d): return [list(elem) for elem..
https://comdoc.tistory.com/entry/Python-Zip-2%EC%B0%A8%EC%9B%90-%EB%B0%B0%EC%97%B4-%ED%9A%8C%EC%A0%84 Python Zip 2차원 배열 회전 1. zip 내장 함수(BIF) zip은 각 iterables의 요소들을 하나씩 모아 이터레이터를 만듭니다. iterable (이터러블) 멤버들을 한 번에 하나씩 돌려줄 수 있는 객체. 이터러블의 예로는 모든 (list, str, tuple 같 comdoc.tistory.com https://choichumji.tistory.com/74 [python] 2차원 리스트 90도 돌리기 def rotated(array_2d): list_of_tuples = zip(*array_2d[::-1])..
https://www.acmicpc.net/problem/1302 1302번: 베스트셀러 첫째 줄에 오늘 하루 동안 팔린 책의 개수 N이 주어진다. 이 값은 1,000보다 작거나 같은 자연수이다. 둘째부터 N개의 줄에 책의 제목이 입력으로 들어온다. 책의 제목의 길이는 50보다 작거나 같고 www.acmicpc.net N = int(input()) S = dict() for _ in range(N): book = input() if book not in S: S[book] = 0 S[book] += 1 print(sorted(list(S.items()), key=lambda x: (-x[1], x[0]))[0][0]) 입력 예제 8 icecream peanuts peanuts chocolate candy..
https://zidarn87.tistory.com/25 파이썬 리스트, 튜플 정렬하기 - sort(), sorted(), reverse() 파이썬 정렬하기 - sort(), sorted(), reverse() sort() 기본값은 오름차순 정렬이고, reverse옵션 True는 내림차순으로 정렬하게 됩니다. a= [3, 1, 9, 7, 5] a.sort() print(a) [1, 3, 5, 7, 9] a= [3, 1,.. zidarn87.tistory.com
https://www.acmicpc.net/problem/1543 1543번: 문서 검색 세준이는 영어로만 이루어진 어떤 문서를 검색하는 함수를 만들려고 한다. 이 함수는 어떤 단어가 총 몇 번 등장하는지 세려고 한다. 그러나, 세준이의 함수는 중복되어 세는 것은 빼고 세야 한 www.acmicpc.net Q = input() A = input() cnt = 0 while Q: if Q[:len(A)] == A: cnt += 1 Q = Q[len(A):] else: Q = Q[1:] print(cnt) 입력 예제 ababababa aba 출력 예제 2 슬라이싱을 활용하여 풀어보았다. while문 종료 조건을 Q가 '' 완전히 빌때까지로 놓았고, 앞부분부터 정답 문자열 길이만큼 슬리이싱한 부분이 A 정답과..
https://www.acmicpc.net/problem/7490 7490번: 0 만들기 각 테스트 케이스에 대해 ASCII 순서에 따라 결과가 0이 되는 모든 수식을 출력한다. 각 테스트 케이스의 결과는 한 줄을 띄워 구분한다. www.acmicpc.net from itertools import product as pd T = int(input()) for _ in range(T): n = input() for operator in list(pd(' +-', repeat=int(n)-1)): formula = '' for idx, op in enumerate(operator, 1): formula += str(idx) + op formula += n if eval(formula.replace(' ', ..
https://chancoding.tistory.com/146 [파이썬] 함수에 입력 변수 여러개 받기 - 매개변수 파이썬에서 함수를 사용할 때 입력 값을 받아서 사용하는 경우가 많습니다. 함수에서 입력 값을 받을 때, 상황에 따라서 입력받는 값의 개수가 달라질 수 있는 경우가 생길 수 있습니다. 예를 들 chancoding.tistory.com
https://www.acmicpc.net/problem/1074 1074번: Z 한수는 크기가 2N × 2N인 2차원 배열을 Z모양으로 탐색하려고 한다. 예를 들어, 2×2배열을 왼쪽 위칸, 오른쪽 위칸, 왼쪽 아래칸, 오른쪽 아래칸 순서대로 방문하면 Z모양이다. N > 1인 경우, 배열을 www.acmicpc.net N, r, c = map(int, input().split()) M = {1: 0} def Z(n, x, y): if n in M: return M[n] else: n //= 2 for i in range(2): for j in range(2): if x < n*(i+1) and y < n*(j+1): ret = (2*i+j)*(n*n) + Z(n, x-n*i, y-n*j) M[n] = ..
https://pyautogui.readthedocs.io/en/latest/keyboard.html#the-hotkey-function Keyboard Control Functions — PyAutoGUI documentation The write() Function The primary keyboard function is write(). This function will type the characters in the string that is passed. To add a delay interval in between pressing each character key, pass an int or float for the interval keyword argument. For pyautogui.re..